Marketplace Unscheduled Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Apr 11, 2022 - 14:16 PDT
Investigating
We are currently undergoing unscheduled Maintenance on the Marketplace. Users may experience degraded performance or may be unable to access or transact on the Marketplace.
Posted Apr 11, 2022 - 07:04 PDT
This incident affected: Second Life Services (Marketplace Purchases).