Unscheduled Linden Home Maintenance

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Mar 10, 2026 - 14:39 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 10, 2026 - 11:05 PDT

Investigating

We are currently investigating the Linden Home selection service, as some Residents are receiving an error message when they attempt to select a new Linden Home. Please follow this blog for updates as we work to fully restore this service for all Residents.
Posted Mar 09, 2026 - 12:48 PDT
This incident affected: Websites (land.secondlife.com).