Concierge Phone Support and Live Chat Unavailable for New Years Eve and Day
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted 3 months ago. Jan 02, 2019 - 06:18 PST
Investigating
Concierge phone and chat support will be unavailable today and tomorrow, December 31st thru January 1st, 2019. Ticket submissions will still be available at this time.
Posted 3 months ago. Dec 31, 2018 - 07:43 PST
This incident affected: External Support (Chat Support, Phone Support).