Phone and Live Chat Support Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Aug 02, 2021 - 04:28 PDT
Investigating
Phone and chat support will be unavailable Sunday, August 1st from 6:00 AM PDT - 2:00 PM PDT. Ticket submissions will still be available at this time.
Posted Aug 01, 2021 - 06:01 PDT
This incident affected: External Support (Chat Support, Phone Support).