Limited availability of new Regions
Incident Report for Second Life
Resolved
In light of more regions being moved to the cloud, we are pleased to announce that we are ready to begin offering new private region purchases in limited quantities. As we continue to uplift more of the grid, more regions will become available over time, eventually leading to the Land Store being reopened. Please read our blog post for more! https://community.secondlife.com/blogs/entry/6348-private-regions-available-in-limited-quantity/
Posted Nov 03, 2020 - 12:33 PST
Identified
New Private Region sales remain on hold. Please keep an eye on our Featured News blog for any major updates regarding new private region sales:
https://community.secondlife.com/blogs/blog/4-featured-news/

Please see https://community.secondlife.com/blogs/entry/4497-limited-availability-of-new-second-life-regions/ for more information and other options for finding land in SL.

It is still possible to manage your current land holdings via land.secondlife.com.
Posted Jul 31, 2020 - 10:20 PDT
Investigating
New Region sales are currently on hold. Please see https://community.secondlife.com/blogs/entry/4497-limited-availability-of-new-second-life-regions/ for more information and other options for finding land in SL.
It is still possible to manage your current land holdings via land.secondlife.com.
Posted May 14, 2020 - 14:30 PDT
This incident affected: Websites (land.secondlife.com).