Unscheduled Second Life Beta Grid Maintenance
Incident Report for Second Life
Resolved
The unscheduled maintenance on the Second Life Beta Grid is now complete. Residents should now be able to log in as normal. Thank you for your patience while we performed this maintenance.
Posted about 1 month ago. Jul 22, 2019 - 11:14 PDT
Investigating
We are currently investigating an issue which may be impacting logins to the Beta Grid, Aditi. Please keep an eye on this blog post for more information.
Posted about 1 month ago. Jul 22, 2019 - 06:45 PDT
This incident affected: Second Life Services (Logins).