Unscheduled Billing Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Mar 26, 2023 - 08:01 PDT
Investigating
We currently undergoing maintenance to billing systems. Residents may experience a longer wait time than usual when making purchases, buy or sell L$, or use the cashier at this time. We hope to restore these services quickly.
Posted Mar 26, 2023 - 06:16 PDT
This incident affected: Second Life Services (LindeX Purchases).