Portal Parks and Linden Realms Maintenance
Incident Report for Second Life
Resolved
The Linden Realms and Portal Parks update is now complete!
Posted 9 days ago. Oct 09, 2018 - 13:11 PDT
Update
Portal Parks are now accessible! However, Linden Realms maintenance is ongoing today, September 27. Residents will not be able to access Linden Realms while this maintenance is in progress. We will provide more information via this blog as it becomes available.
Posted 21 days ago. Sep 27, 2018 - 08:22 PDT
Investigating
We are performing maintenance on the Portal Parks and Linden Realms today, September 26. During maintenance, residents will not be able to access Portal Parks or Linden Realms. Please keep an eye on this blog for further updates as they become available.
Posted 22 days ago. Sep 26, 2018 - 08:22 PDT