Portal Park Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted 25 days ago. Nov 19, 2018 - 08:36 PST
Investigating
We are currently undergoing maintenance for Portal Park. During this maintenance, Residents will not be able to access Portal Park. Please keep an eye on this blog for further updates as they become available.
Posted 25 days ago. Nov 19, 2018 - 06:31 PST