Unschedule Maintenance
Incident Report for Second Life
Resolved
Maintenance has been completed and the incident has been resolved. If you are still experiencing issues regarding accessing a region or teleporting to it, please reach out to customer support.
Posted Nov 14, 2019 - 09:48 PST
Investigating
We are currently investigating an issue that has affected access to a number of regions. During this time you may get teleport failures, or the region might appear to be offline.
Posted Nov 13, 2019 - 23:09 PST
This incident affected: Second Life Regions (Second Life Main Channel Regions, Second Life Release Candidate Regions).