Second Life Community Currently Unavailable

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Oct 21, 2020 - 16:52 PDT

Investigating

We are aware that Residents are unable to access the Community pages, and we're currently investigating it. Please keep an eye on this blog for further updates.
Posted Oct 21, 2020 - 16:27 PDT
This incident affected: Websites (community.secondlife.com).