Issue Viewing L$ Transaction History

Incident Report for Second Life

Resolved

This issue has been resolved. If you are still unable to access your L$ Transaction Log on any of your accounts, please contact support so that we may assist you further.
Posted Jan 02, 2026 - 16:31 PST

Identified

The issue has been identified, and we plan on having a fix implemented as soon as possible.
Posted Jan 02, 2026 - 12:30 PST

Investigating

We have currently identified the cause of the issue where some residents may have trouble viewing their L$ Transaction History and are currently working on a fix. We apologize for the inconvenience this may cause. We’ll share more updates on this blog as they become available. Thank you for your patience.
Posted Jan 02, 2026 - 07:41 PST
This incident affected: Websites (secondlife.com) and Inworld Services (L$ Transactions).