Phone and Chat Support Unavailable
Incident Report for Second Life
Resolved
Phones and chat are open again.
Posted 4 months ago. Mar 17, 2017 - 13:02 PDT
Investigating
Phone and chat support will be unavailable from 12:00 noon to 1:00 PM PDT, March 17th, 2017. Case submissions are still available.
Posted 4 months ago. Mar 17, 2017 - 11:27 PDT
This incident affected: External Support (Chat Support, Phone Support).