Concierge Phone Support and Live Chat Unavailable
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted 2 months ago. Apr 11, 2019 - 14:30 PDT
Investigating
Concierge phone and chat support will be unavailable from 1:30 PDT to 2:30 PM PDT today, April 11, 2019. Ticket submissions will still be available at this time.
Posted 2 months ago. Apr 11, 2019 - 14:12 PDT
This incident affected: External Support (Chat Support, Phone Support).