Weekly Premium Stipends Delayed
Incident Report for Second Life
Resolved
This week's Premium Stipends have been dispersed. For any residents that did not receive today's stipend please contact Support.
Posted 2 months ago. Sep 04, 2018 - 07:58 PDT
Investigating
We are aware that some residents Weekly Premium Stipends have been delayed. We are in the process of getting those out. We will update this blog when that has been completed. Thank you for your patience!
Posted 2 months ago. Sep 04, 2018 - 06:45 PDT