Billing Issues
Incident Report for Second Life
Resolved
The issue possibly impacting Mastercard transactions has been resolved.
Posted 6 months ago. Jun 21, 2018 - 15:05 PDT
Investigating
We are currently investigating an issue that may cause some Mastercard transactions to fail. This may also prevent Mastercards from being added as payment methods. Please monitor this blog for updates.
Posted 6 months ago. Jun 21, 2018 - 10:26 PDT
This incident affected: Second Life Services (LindeX Purchases, Marketplace Purchases).