Premium Stipends Delayed
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Sep 30, 2020 - 06:21 PDT
Investigating
We are aware the Stipends for this week have been delayed for some Premium members. We are investigating the issue, and expect them to be paid out soon. Please monitor this blog for updates.
Posted Sep 29, 2020 - 07:03 PDT