Concierge Phone Support and Live Chat Unavailable
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted 3 months ago. Dec 27, 2018 - 11:08 PST
Investigating
Concierge phone and chat support will be unavailable from 10:00 AM PDT to 11:00 AM PDT today, December 27th, 2018. Ticket submissions will still be available at this time.
Posted 3 months ago. Dec 27, 2018 - 10:02 PST
This incident affected: External Support (Chat Support, Phone Support).