Email regarding International Billing
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted 3 months ago. Sep 29, 2017 - 05:14 PDT
Monitoring
Last week, we posted a blog about some upcoming work on our International Billing system here: https://community.secondlife.com/blogs/entry/2251-important-update-for-international-credit-card-users/ This week, Linden Lab did send out email to users that may be affected. If you think you may be affected by these changes, please log into your account and update your billing information.
Posted 3 months ago. Sep 26, 2017 - 18:38 PDT
This incident affected: Second Life Services (LindeX Purchases, Marketplace Purchases, Process Credits).