Unscheduled Maintenance for my.secondlife.com
Incident Report for Second Life
Resolved
The issue with my.secondlife.com has been resolved.
Posted 3 months ago. Apr 25, 2019 - 15:38 PDT
Investigating
We are currently investigating an issue with my.secondlife.com. Access to my.secondlife.com or updates to profiles may be impacted during this time. Please monitor this blog for updates.

Thank you for your patience during this time.
Posted 3 months ago. Apr 25, 2019 - 15:21 PDT
This incident affected: Websites (my.secondlife.com).