Secondlife.com Login Issues
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Dec 17, 2020 - 12:00 PST
Investigating
Some Second Life Residents are currently experiencing trouble logging into secondlife.com. Our engineers are investigating this issue, and hope to have this resolved shortly. Please monitor this blog for additional updates
Posted Dec 17, 2020 - 08:23 PST
This incident affected: Second Life Services (Logins) and Websites (secondlife.com).