Delay In Newly Purchased Regions

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Mar 04, 2021 - 07:58 PST

Investigating

New regions delivered by the Land Store may be delayed temporarily. Please allow up to 24 hours for new regions to be available in world. Thank you for your patience! Please follow this blog for updates.
Posted Feb 26, 2021 - 10:42 PST
This incident affected: Websites (land.secondlife.com).