Unscheduled Concierge Phone Maintenance
Incident Report for Second Life
Resolved
This maintenance has been completed.
Posted 10 days ago. Oct 08, 2018 - 05:59 PDT
Investigating
Concierge phone support will be unavailable today, October 7th, 2018. Live chat and ticket submissions will still be available at this time.
Posted 11 days ago. Oct 07, 2018 - 11:00 PDT
This incident affected: External Support (Phone Support).