Live Chat Support Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Mar 26, 2024 - 10:23 PDT
Investigating
Live Chat support is open as scheduled. However, the service is currently experiencing degraded performance that may lead to delayed response from agents in chat. We apologize for any inconvenience, and thank you for your patience.

Please follow this blog for updates.
Posted Mar 26, 2024 - 08:27 PDT
This incident affected: External Support (Chat Support) and Websites (support.secondlife.com).