Unscheduled Credit Processing Maintenance
Incident Report for Second Life
Resolved
Process credit requests from Second Life accounts to Skrill accounts are now completing normally. We are continuing to process some of the requests filed during this maintenance, and expect to have them completed shortly. We appreciate your patience!
Posted 19 days ago. Jul 03, 2018 - 14:51 PDT
Investigating
We are aware that there has recently been a temporary delay in the completion of process credit requests from Second Life accounts to Skrill accounts. We are investigating and will have the situation resolved and all requests processed as quickly as possible. If you are waiting on a process credit request, we ask that you do not re-submit it. Thank you for your patience while we investigate this issue and resolve it.
Posted 23 days ago. Jun 29, 2018 - 15:01 PDT
This incident affected: Second Life Services (Process Credits).