Live Chat Support Connection Issues
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted about 1 month ago. Aug 17, 2018 - 15:00 PDT
Investigating
Live chat support may be unavailable as we are investigating intermittent connection issues with our chat provider. Live phone support and ticket submissions will still be available at this time. Please follow this blog for updates
Posted about 1 month ago. Aug 17, 2018 - 12:37 PDT
This incident affected: External Support (Chat Support).