Unscheduled Community Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted 3 months ago. May 10, 2018 - 12:00 PDT
Investigating
We are currently undergoing unscheduled maintenance to the Second Life Community and Forum sites. Some residents may not be able to access the Community site and associated Second Life Forums. Please keep an eye on this blog for further updates as they become available.
Posted 3 months ago. May 10, 2018 - 11:37 PDT
This incident affected: Websites (community.secondlife.com).