Support Phones down for Unscheduled Maintenance
Incident Report for Second Life
Resolved
The unscheduled maintenance has finished.
Posted 5 months ago. Jul 17, 2018 - 13:27 PDT
Investigating
We are currently performing unscheduled maintenance to our support phone lines. Residents can still reach support through other channels available through their dashboard. Please check here for updates.
Posted 5 months ago. Jul 17, 2018 - 12:56 PDT
This incident affected: External Support (Phone Support).