Second Life Service Issues
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Jan 30, 2020 - 11:49 PST
Update
We are continuing to investigate this issue.
Posted Jan 30, 2020 - 11:13 PST
Investigating
We are currently investigating an issue that may cause some services to be unavailable including, but not limited to: secondlife.com , land.secondlife.com, and chat support.

Please stay tuned to this blog for more updates.
Posted Jan 30, 2020 - 11:12 PST
This incident affected: Websites (secondlife.com, support.secondlife.com) and External Support (Chat Support).