Unscheduled Voice Server Maintenance
Incident Report for Second Life
Resolved
The Unscheduled Voice Server Maintenance has been resolved.

We thank you for your patience.
Posted 28 days ago. Apr 24, 2018 - 16:58 PDT
Investigating
We are currently aware of an issue affecting in world voice. We appreciate your patience while we investigate this issue.
Posted about 1 month ago. Apr 21, 2018 - 12:12 PDT