Unscheduled Dashboard Login Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Feb 17, 2024 - 04:48 PST
Investigating
Some residents may experience errors when attempting to log in to www.secondlife.com. These residents should be able to work around this by going directly to support.secondlife.com, logging in, then clicking the Second Life logo at the top left. Please watch this status blog post for updates.
Posted Feb 16, 2024 - 19:18 PST
This incident affected: Websites (secondlife.com).