Unscheduled Payout Maintenance

Incident Report for Second Life

Resolved

This incident has been resolved. Thank you for your patience.
Posted Mar 18, 2025 - 14:01 PDT

Monitoring

A fix has been implemented, and we are monitoring the results. Thank you for your patience. We’ll share updates as soon as we have more information.
Posted Mar 18, 2025 - 05:57 PDT

Identified

We’ve identified the issue and are working on a fix. Thank you for your patience, and we’ll share updates as soon as we have more information.
Posted Mar 17, 2025 - 13:20 PDT

Investigating

We're aware that some residents are encountering issues when submitting payout requests. To address this, we’ll be performing unscheduled maintenance on the payout system. We appreciate your patience and will provide updates as soon as more information becomes available.
Posted Mar 17, 2025 - 08:12 PDT
This incident affected: Second Life Services (Process Credits).