Unscheduled Skrill Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Nov 24, 2020 - 19:54 PST
Investigating
We are aware of Residents experiencing issues with Skrill related transactions and are currently investigating. Please keep an eye on this blog for updates
Posted Nov 24, 2020 - 11:05 PST
This incident affected: Second Life Services (LindeX Purchases, Marketplace Purchases, Process Credits) and Inworld Services (L$ Transactions).