Unscheduled Live Chat Maintenance

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Nov 21, 2025 - 06:21 PST

Investigating

We are currently investigating an issue which is preventing access to Live Chat. Phone Support and Ticket Submissions are still available.
Posted Nov 20, 2025 - 13:57 PST
This incident affected: External Support (Chat Support).