Unscheduled Support Maintenance
Incident Report for Second Life
Resolved
Second Life phone and chat support are now available and no longer under maintenance.
Posted 5 months ago. Mar 22, 2019 - 10:32 PDT
Investigating
Second Life phone and live chat support are currently undergoing unscheduled maintenance and are not currently available. We are still receiving submitted support cases, however. Regular phone and live chat support access will resume later and updates will be posted here as they become available.
Posted 5 months ago. Mar 22, 2019 - 09:25 PDT
This incident affected: External Support (Chat Support, Phone Support).