Issues with LindeX orders

Incident Report for Second Life

Resolved

This incident has been resolved, and refunds for undelivered LindeX orders have been issued.
Posted Feb 21, 2025 - 09:22 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 18, 2025 - 15:29 PST

Investigating

We are seeing a higher-than-normal incidence of issues with orders placed through LindeX. Our engineers are currently investigating the issue. Please watch this blog for any updates.
Posted Feb 18, 2025 - 13:26 PST
This incident affected: Second Life Services (LindeX Purchases).