Unscheduled Live Chat Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Feb 20, 2020 - 14:11 PST
Investigating
We are aware of an issue with live chat support not sending/receiving messages properly and we are currently investigating. Ticket submissions are still available during this time if you are experiencing issues contacting support via live chat.
Posted Feb 20, 2020 - 11:01 PST
This incident affected: External Support (Chat Support).