My.secondlife.com Outage
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted May 18, 2021 - 10:20 PDT
Investigating
My.secondlife.com is currently unavailable. While we work to bring this service back online, both my.secondlife.com and in-world profiles will be inaccessible.

We will update this blog when this web service has been restored.
Posted May 18, 2021 - 09:24 PDT
This incident affected: Inworld Services (Profiles) and Websites (my.secondlife.com).