Unscheduled Marketplace Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Jan 15, 2020 - 18:39 PST
Investigating
We are currently aware of issues where the Second Life Marketplace is slow to load/respond. Our engineers are working to resolve these issues as soon as possible.

Please check this blog for updates.
Posted Jan 15, 2020 - 15:56 PST
This incident affected: Websites (marketplace.secondlife.com).