Unscheduled Billing Maintenance
Incident Report for Second Life
Resolved
We have completed the unscheduled billing maintenance.

Thank you for your patience during this time.
Posted Feb 10, 2020 - 16:01 PST
Update
We are continuing to investigate this issue.
Posted Feb 10, 2020 - 15:11 PST
Investigating
We are currently investigating an issue affecting our billing and payments systems. While this maintenance is in progress, residents may be unable to use the cashier or make purchases. Please watch this blog for updates.
Posted Feb 10, 2020 - 15:09 PST
This incident affected: Websites (secondlife.com, marketplace.secondlife.com, my.secondlife.com) and Second Life Services (Logins, LindeX Purchases, Marketplace Purchases).