Phone Support Issues
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Oct 09, 2020 - 15:03 PDT
Investigating
Callers to our phone support may experience dropped calls or poor call quality. We are investigating this issue now. Please watch this blog for updates.
Posted Oct 09, 2020 - 10:49 PDT
This incident affected: External Support (Phone Support).