Profile Issues
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Apr 12, 2021 - 15:49 PDT
Investigating
We are aware that some Residents may be having trouble accessing my.secondlife.com and in world profiles.

We are currently investigating and thank you for your patience. Please follow this blog for updates.
Posted Apr 12, 2021 - 14:02 PDT
This incident affected: Inworld Services (Profiles) and Websites (my.secondlife.com).