Profile Services Undergoing Unscheduled Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted 5 months ago. Aug 02, 2017 - 17:16 PDT
Investigating
We are currently investigating this issue.
Posted 5 months ago. Aug 02, 2017 - 16:59 PDT
This incident affected: Inworld Services and Websites (my.secondlife.com).