A fix has been implemented and we are monitoring the results.
Posted Apr 25, 2026 - 14:41 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 25, 2026 - 13:12 PDT
Update
We are continuing to investigate this issue.
Posted Apr 25, 2026 - 12:59 PDT
Update
We are continuing to investigate this issue.
Posted Apr 25, 2026 - 12:58 PDT
Update
We are continuing to investigate this issue.
Posted Apr 25, 2026 - 12:45 PDT
Investigating
We are undergoing inventory maintenance on April 25th 2026 at 12:40 PM Pacific Time. Please be advised that in-world inventory access, Login activity, rezzing objects, displaying avatars, and loading times may be temporarily impacted during maintenance. Our engineers are working on resolving this issue as soon as possible.
Posted Apr 25, 2026 - 12:44 PDT
This incident affects: Second Life Services (Logins, Marketplace Purchases) and Inworld Services (Rezzing, Inventory).