Premium Plus Sign Up Bonuses
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Aug 09, 2022 - 12:08 PDT
Investigating
We have received reports that some Residents who upgraded to Premium Plus have received sign up bonuses of L$2000 rather than the L$3000 they may have expected.

We have reviewed the Premium Plus sign up bonus structure and we have good news! We will be updating the structure so that a full L$3000 for those yet to receive your sign up bonus!

For those who have already received your premium plus signup bonus, don't worry! We'll be making sure you get an extra L$1000 in the coming days!
Posted Aug 08, 2022 - 12:46 PDT