SL15B Gift Week 15 Not Delivering
Incident Report for Second Life
Resolved
The Gift Grab issue has been resolved.
Posted 24 days ago. Sep 24, 2018 - 07:39 PDT
Investigating
Residents may experience issues collecting the SL15B Gift Grab for this week. An error message may pop up when clicking on the chest to collect the gift. We are actively investigating this, and we will update this post when the issue has been resolved.
Posted 24 days ago. Sep 24, 2018 - 06:49 PDT