Unscheduled Second Life webpage Maintenance

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Apr 16, 2025 - 13:08 PDT

Update

We are continuing to monitor for any further issues.
Posted Apr 16, 2025 - 12:52 PDT

Monitoring

We are performing an unscheduled maintenance Secondlife.com and other web properties. Residents may experience issues accessing Secondlife.com and the Second Life Marketplace. Please keep an eye on this blog for status updates
Posted Apr 16, 2025 - 12:50 PDT
This incident affected: Websites (secondlife.com, marketplace.secondlife.com, my.secondlife.com, support.secondlife.com).