Second Life Marketplace Errors
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Apr 08, 2020 - 19:12 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 08, 2020 - 18:45 PDT
Investigating
We are aware that Residents are receiving errors while trying to access the Second Life Marketplace. Our operations team is investigating.
Posted Apr 08, 2020 - 18:26 PDT
This incident affected: Websites (marketplace.secondlife.com).