Unscheduled Maintenance to My.Secondlife.com
Incident Report for Second Life
Resolved
The unscheduled maintenance has been completed.
Posted Dec 28, 2020 - 14:14 PST
Investigating
We are currently investigating on the issue with my.secondlife.com. Access to my.secondlife.com may be impacted during this time. Please monitor this blog for updates.
Posted Dec 28, 2020 - 12:29 PST
This incident affected: Websites (my.secondlife.com).