Unscheduled Maintenance with Profiles
Incident Report for Second Life
Resolved
The unscheduled maintenance has been resolved.
Posted 19 days ago. Aug 05, 2019 - 12:04 PDT
Investigating
We are currently investigating a couple issues with our profile system such as deleting posts and images. We'll update this blog as soon as we have more information.
Posted 19 days ago. Aug 05, 2019 - 09:56 PDT